XMLmind XML Editor - Online Help

Hussein Shafie

XMLmind Software

35 rue Louis Leblanc,
78120 Rambouillet,
France,
Phone: +33 (0)9 52 80 80 37,
Web: www.xmlmind.com/xmleditor
Email:  (public mailing list)

December 12, 2017

Abstract

This online help contains, in addition to a short tutorial, the reference manual of all the menus, tool bars and dialog boxes of XMLmind XML Editor (XXE for short).


Table of Contents

I. Getting started
1. Install
1. Installing XMLmind XML Editor (XXE for short)
2. Contents of the installation directory
3. Acknowledgments
2. Getting started with XMLmind XML Editor
II. Reference
3. Menus
1. File menu
1.1. Folder menu
2. Select menu
2.1. The selection in XXE
2.1.1. Text selection
2.1.2. Node selection
2.1.3. Implicit element selection
2.2. Select menu items
2.2.1. Link submenu
2.2.2. Navigation submenu
3. Edit menu
3.1. Comment menu
3.2. Processing instruction menu
3.3. Reference menu
4. Search menu
4.1. Web Search menu
5. View menu
5.1. The "XML source" menu item
6. Tools menu
6.1. Spreadsheet menu
6.2. Remark menu
6.3. Revisions menu
6.4. "Helper Application" menu
6.5. "Record Macro" menu
7. XML menu
8. Options menu
8.1. "Customize Configuration" menu
9. Window menu
10. Help menu
4. The document view area
5. Tool bars
1. Configuration specific tool bar
6. The node selection bar
1. The node path bar
1.1. Non-editable nodes
1.2. Elements which are in non-validating mode
2. Navigation tool bar
7. Tools
1. Edit tool
2. Include tool
2.1. Working with XML variables
2.2. Using the Include tool
3. Attributes tool
3.1. Using the attribute table
3.1.1. Reducing the number of attributes displayed by the attribute table
3.2. Using the attribute form
4. Search tool
5. Character tool
5.1. The “Favorites” palette
6. Validity tool
7. The "Browse Files" tool
7.1. Opening and comparing revisions of a document
8. The "Search Files" tool
8.1. The "Create or edit an advanced query" dialog box
8.2. Syntax of search queries
9. The Compare tool
9.1. Why use the Compare tool?
9.2. Using the Compare tool
8. Status bar
1. Validity state
2. Document cache indicator
3. Status messages
4. Spell checker
5. Overwrite mode
6. Clipboard utilities
6.1. Clipboard content
9. Dialog boxes
1. The URL chooser dialog box
1.1. The "Document conversion parameters" panel
2. The "Find Element" dialog box
2.1. The "Simple" tab
2.2. The "Advanced" tab
3. The "Declare Namespace" dialog box
4. The "Attribute Value" dialog box
5. The spreadsheet formula editor
6. The "Check Spelling" dialog box
7. The "Preferences" dialog box
7.1. New options
7.2. Open options
7.3. Save options
7.4. Print options
7.5. Edit options
7.6. Web search options
7.7. View options
7.7.1. "CSS stylesheet defaults" subsection
7.7.2. "Tree view settings" subsection
7.7.3. Preferences related to tags
7.7.4. Preferences related to images
7.8. Tools options
7.8.1. Master document options
7.8.2. Validate options
7.8.3. Spell options
7.8.4. Spreadsheet options
7.8.5. Revisions options
7.8.6. Helper applications options
7.9. Install add-ons options
7.10. General options
7.10.1. Features Options
7.11. Advanced options
7.11.1. Cached data options
7.11.2. Proxies options
7.12. Add-on options
7.12.1. Apache FOP options
7.12.2. RenderX XEP options
8. The "Tree view fonts and colors" dialog box
9. The "Helper Application Editor" dialog box
10. The "Save Document As Template" dialog box
10.1. Organizing the content of the FileNew dialog box
10.2. Removing a previously defined document template
11. The "Save Selected Element as Template" dialog box
11.1. Advanced options
11.2. Removing a previously defined element template
12. The "Add Keyboard Shortcut" dialog box
12.1. Removing a previously defined keyboard shortcut
13. The "Customize CSS Stylesheet" dialog box
13.1. Quickly customizing the style of selected element
14. The "Customize Document Conversion Stylesheets" dialog box
14.1. Introduction
14.2. Reference
14.3. The "XMLmind XSL Customizer" application
14.3.1. Introduction
14.3.2. Reference
15. The "Install Add-ons" dialog box
16. Dialog box allowing to edit “text style” menu items
16.1. Dialog box allowing to edit a “text style” menu item
17. The media player dialog box
17.1. Adding audio or video to your document
17.2. Using the media player dialog box
17.2.1. The Media tab
17.2.2. The Setup tab
18. The "Edit Image Map" dialog box
18.1. Adding an image map to your document
18.2. Using the image map editor
18.2.1. The toolbar of the image map editor
18.2.2. Specifying the link target and optionally the link text of selected area
18.3. Creating and using an annotated variant of image file
A. Command line options
1. Command line
2. Preference keys
3. Environment variables
4. System properties

List of Figures

3.1. Perform a web search using Google by pressing F3 and then g
3.2. A remark made by use bart and its tooltip.
3.3. The "Open Revision" dialog box, here allowing to compare the document being edited (revision #4; latest one) to the initial revision (revision #1)
3.4. The "Helper Application Not Found" dialog box
4.1. Tab corresponding to the active document
4.2. Tab corresponding to the active document when it is in read-only mode
7.1. Popup menu when a DITA element is selected
7.2. The "Browse Files" tool showing the source files of our DITA tutorial
7.3. The "List Revisions" dialog box
7.4. Search our DITA tutorial for topic files (*.dita) containing substring "link"
7.5. The "Create or edit an advanced query" dialog box
7.6. The Compare tool showing the differences existing between doc.xml 1 (initial revision) and doc.xml (latest revision), displayed side by side
7.7. The Compare tool showing change #2
9.1. An URL chooser dialog box having an expanded "Document conversion parameters" panel
9.2. Composition area displayed below the caret
9.3. Dialog box allowing to add or edit a web search service specification
9.4. The "FOP" preferences sheet
9.5. The "Choose a TTF font and specify its aliases" dialog box
9.6. The "Customize CSS Stylesheet" dialog box
9.7. Right-click popup menu of the "Customize CSS Stylesheet" dialog box
9.8. An easy to use style editor
9.9. The "CSS Source" tab of the style editor
9.10. Converting an XML document to an XSL-FO based format
9.11. Converting an XML document to an HTML-based format
9.12. The "Customize Document Conversion Stylesheets" dialog box showing the stylesheets used when a DITA map is converted to single-page XHTML
9.13. "XMLmind XSL Customizer" main window
9.14. The Add/Edit attribute dialog box
9.15. The Add/Edit parameter dialog box
9.16. Toggles found at the beginning of the DocBook tool bar
9.17. Customizing the items of the DocBook' “italic text style” menu
9.18. The menu item editor
9.19. Two embedded media players, one for video and the other for audio, both having controls
9.20. The right-click popup menu of a media player (audio only, no controls)
9.21. The Media tab of the media player dialog box
9.22. The Setup tab of the media player dialog box
9.23. The right-click, contextual, popup menu has an "Edit Image Map" entry
9.24. The "Edit Image Map" dialog box
9.25. The "Edit image map area" dialog box
9.26. The popup menu displayed by clicking the "Create and use an annotated variant of image file" toolbar button
9.27. Example of annotated image preceding an XHTML map

List of Tables

9.1. Lock Types
9.2. Substituted Variables

List of Examples

3.1. A use case for command Force Deletion
3.2. Example: book referencing chapters
3.3. Example explaining the enhanced cross-reference creation/validation provided by a master document
9.1. Default language versus actual language example
9.2. When converting a DITA map to PDF, use a 12pt base font size and give a light gray background to all the topic titles
9.3. When converting a DITA map to single-page XHTML, use a 12pt base font size and give a light gray background to all the topic titles
9.4. When converting a DITA map to PDF, give a light gray background to all the topic titles
9.5. When converting a DITA map to PDF, use a 12pt base font size