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1. About DITA support in XMLmind XML Editor

Out of the box, XMLmind XML Editor (XXE for short) allows to edit topics, maps and bookmaps conforming to
the DITA 1.1 DTD or W3C XML Schema.

By default, DITA documents created using XXE conform to the DTD and not to the W3C XML Schema, but this
can be easily changed by customizing the DITA configuration as explained in XMLmind XML Editor - Configuration
and Deployment.

As of version 4.5, XXE no longer relies on the DITA Open Toolkit to convert DITA documents to formats such
as XHTML, PDF, RTF, etc. Instead XXE embeds XMLmind DITA Converter:

XMLmind DITA Converter (ditac for short) allows to convert the most complex DITA 1.1
documents to production-quality XHTML 1.0, XHTML 1.1, HTML 4.1, Java™ Help, HTML
Help, PDF, PostScript®, RTF (can be opened in Word 2000+), WordprocessingML (can be
opened in Word 2003+), Office Open XML (.docx, can be opened in Word 2007+), OpenOffice
(.odt, can be opened in OpenOffice.org 2+).

XMLmind DITA Converter is free, open source, software licensed under the very liberal terms
of the Mozilla Public License version 1.1.

All this makes XMLmind DITA Converter a very serious alternative to using the DITA Open
Toolkit.

More information in http://www.xmlmind.com/ditac/.

2. DITA topic reference

2.1. DITA topic menu

When a DITA topic (of any kind) is opened in XMLmind XML Editor, the XML menu becomes the Topic menu
and this menu is populated with items which are specific to DITA topics. This reference contains a description of
such menu items.

Table editor

This table editor may be used to edit simpletables as well as CALS tables. Note that using this table editor,
or simply saving a topic, or checking a topic for validity, guarantees that the cols attribute of a tgroup is up to
date. That is, you may forget about the cols attribute, XMLmind XML Editor will always compute it for you.

DescriptionItemMenu

Insert a column before column containing specified cell. Insert BeforeColumn

Insert a column after column containing specified cell. Insert AfterFor a command in
this menu to

Cut to the clipboard the column containing specified cell. Cutwork, click
Copy to the clipboard the column containing specified cell. Copyanywhere inside a

cell(1). Paste copied or cut column before column containing specified cell. Paste Before

Paste copied or cut column after column containing specified cell. Paste After

Delete the column containing specified cell. Delete

Insert a row before row containing specified cell. Insert BeforeRow

(1)or explicitly select a cell or an element having a cell ancestor

1

XMLmind XML Editor - DITA Support

http://www.xmlmind.com/xmleditor/_distrib/doc/configure/customizing.html
http://www.xmlmind.com/xmleditor/_distrib/doc/configure/customizing.html
http://dita-ot.sourceforge.net/
http://www.xmlmind.com/ditac/
http://www.mozilla.org/MPL/MPL-1.1.html
http://dita-ot.sourceforge.net/
http://dita-ot.sourceforge.net/
http://www.xmlmind.com/ditac/


DescriptionItemMenu

For a command in
this menu to

Note that row editing commands are enabled, not only by implicitly
or explicitly selecting a table cell or any of its descendants, but
also by explicitly selecting a table row.

Note

work, click
anywhere inside a

cell(1) or
Insert a row before row containing specified cell. Insert Afterexplicitly select a

row. Cut to the clipboard the row containing specified cell. Cut

Copy to the clipboard the row containing specified cell. Copy

Paste copied or cut row before row containing specified cell. Paste Before

Paste copied or cut row after row containing specified cell. Paste After

Delete the row containing specified cell. Delete

Increment the number of columns spanned by specified cell. Not relevant
for simpletables.

 Increment
Column Span

Cell

For a command in
this menu to Decrement the number of columns spanned by specified cell. Not relevant

for simpletables.
 Decrement

Column Spanwork, click
anywhere inside a

cell(1).
Increment the number of rows spanned by specified cell. Not relevant for
simpletables.

 Increment Row
Span

Decrement the number of rows spanned by specified cell. Not relevant for
simpletables.

 Decrement
Row Span

Indexterm editor

Insert or Edit indexterm
If the caret is anywhere inside an indexterm element, this menu item displays an indexterm editor
dialog box allowing to modify this indexterm element.

If the caret is not inside an indexterm element, this menu item displays an indexterm editor dialog
box allowing to create a new indexterm element and then to insert it at caret position.

Cross-reference tools

In addition to the following tools, cross-references are automatically checked each time the topic being edited is
saved (Ctrl-S) or is checked for validity (Ctrl+Shift-V or the Check Validity iconic button found at the left of the
status bar).

Go to Opposite Link End
An element having a conref, href or an id attribute must be implicitly or explicitly selected. Scrolls
to and selects the opposite link end (if found).

Go to Next Link
An element with a conref or an href attribute must be implicitly or explicitly selected. Scrolls to and
selects following similar link (if found).

Go to Previous Link
An element with a conref or an href attribute must be implicitly or explicitly selected. Scrolls to and
selects preceding similar link (if found).

Go to...

Displays a dialog box listing all the fully qualified IDs(2) defined in the document being edited.

(2)For example, if a p has id attribute "disclaimer" and has an ancestor concept with id attribute "introduction", its fully
qualified ID is "introduction/disclaimer".
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This dialog box, which supports auto-completion, has four buttons:

Go to Target
Scroll to and select the element having selected ID.

Go to First Reference
Scroll to and select the first element referencing selected ID in its conref or href attribute.

Copy Fragment
Copy selected ID preceded by character "#" (that is, a ready-to-paste reference) to the clipboard.
Examples: "#quickStart", "#quickStart/commandList".

Copy URL
Same as Copy Fragment, except that the fragment is preceded by the basename of the document
being edited. Examples: "getting%20started.dita#quickStart",
"getting%20started.dita#quickStart/commandList".

The Copy Fragment and Copy URL buttons of the Go to dialog box are intended to be used to
specify the href attribute of the xref and link elements.

Tip

Convert Document menu

Note • This menu is absent in XMLmind XML Editor Personal Edition.
• The items of this menu are all disabled if the document being edited needs to be saved to

disk.

Convert to XHTML
Convert to XHTML [one page]

Converts the document being edited to multi page or single page XHTML 1.0.

Convert to HTML Help
Converts the document being edited to a .chm file. This command is disabled on platforms other than
Windows.

Requires:

1. Download and install Microsoft®'s HTML Help Workshop.
2. Declare the HTML Help compiler, hhc.exe, as the helper application associated to files having a

"hhp" extension. This can be specified by using the Preferences dialog box, Helper Applications
section.

Convert to Java Help
Converts the document being edited to a .jar file for use by the Java™ Help system.

Requires:

1. Download and install JavaHelp.
2. Declare the Java™ Help indexer, jhindexer (jhindexer.bat on Windows), as the helper

application associated to files having a "application/x-java-help-index" MIME type. This
can be specified by using the Preferences dialog box, Helper Applications section.

Convert to RTF (Word 2000+)
Converts the document being edited to RTF (Rich Text Format) using. The document generated by this
command can be edited and printed using Microsoft® Word 2000 and above.

Requires downloading and installing the "XMLmind FO Converter XSL-FO processor plug-in " add-on

using Options → Install add-ons.

Convert to WordprocessingML (Word 2003+)
Converts the document being edited to WordprocessingML. The document generated by this command
can be edited and printed using Microsoft® Word 2003 and above.
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Same requirements as Convert to RTF.

Convert to Office Open XML (Word 2007+)
Converts the document being edited to Office Open XML (.docx file) . The document generated by this
command can be edited and printed using Microsoft® Word 2007 and above.

Same requirements as Convert to RTF.

Convert to OpenDocument (OpenOffice.org 2+)
Converts the document being edited to OpenDocument (.odt file). The document generated by this
command can be edited and printed using OpenOffice.org 2.

Same requirements as Convert to RTF.

Print PostScript
Convert the document being edited to PostScript® and send the generated file to the chosen printer.

Requires downloading and installing any of the following add-ons using Options → Install add-ons.

• Apache FOP 1.x XSL-FO processor plug-in;

• RenderX XEP XSL-FO processor plug-in(3).

Convert to PDF
Convert the document being edited to PDF.

Same requirements as Print PostScript.

2.2. DITA topic tool bar

When a DITA topic (of any kind) is opened in XMLmind XML Editor, buttons which are specific to this kind of
document are automatically added to the tool bar. This reference contains a description of such buttons.

DescriptionButton

Convert selected text or implicitly or explicitly selected element to an i element. Convert to i

Convert selected text or implicitly or explicitly selected element to an b element. Convert to b

Convert selected text or implicitly or explicitly selected element to an tt element. Convert to tt

Convert selected text or implicitly or explicitly selected element to an xref element. Convert to xref

Convert selected text or implicitly or explicitly selected element to plain text. Convert to plain text

Add a p after node selection or after caret at a location where it is valid to do so and
where it makes sense to do so.

Add p

This command and all the following commands will never add an element
inside a p, even it is valid to do so. These commands add elements always

Note

after a p. That is, a p element is always considered by these commands as
being a plain paragraph and never as being a division.

Add a list item of the right type after current list item. For this command to work,
suffice to click anywhere inside an sl, ul, ol, dl, choices, substeps, steps,
steps-unordered.

Add list item

(3)Unlike all the other add-ons, the RenderX XEP XSL-FO processor plug-in is not self-contained. You'll need to download, install
and activate RenderX XEP (for example, free Personal Edition) prior to using the RenderX XEP XSL-FO processor plug-in.
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DescriptionButton

Add an ul after node selection or after caret at a location where it is valid to do so
and where it makes sense to do so (see note).

Add ul

Add an ol after node selection or after caret at a location where it is valid to do so
and where it makes sense to do so (see note).

Add ol

Add a dl after node selection or after caret at a location where it is valid to do so and
where it makes sense to do so (see note).

Add dl

Displays a menu which allows to add a simpletable or a table after node selection
or after caret at a location where it is valid to do so and where it makes sense to do
so (see note).

Add table

Displays a menu which allows toAdd image

• insert an image at caret position;

• OR add a fig (containing an image) after node selection or after caret at a
location where it is valid to do so and where it makes sense to do so (see note).

Add a section after node selection or after caret at a location where it is valid to
do so and where it makes sense to do so (see note).

Add section

Open in XMLmind XML Editor the topic referenced in the conref or href attribute
of selected element.

 Edit referenced topic

If this document is already opened in XMLmind XML Editor, this command brings
its view to front and makes it the active one.

Use the Web browser to display the documentation of the element explicitly or
implicitly selected. (Contributed by Mark Fletcher.)

 Browse the DITA
reference manual found on
the OASIS Web site Requires to be connected to the Internet because the reference manual of DITA

elements is found on the OASIS Web site.

2.3. DITA topic bindings

When a DITA topic (of any kind) is opened in XMLmind XML Editor, additional keyboard shortcuts and additional
drag and drop facilities which are specific to this kind of document are automatically made available to the user.
This reference contains a description of such user input/command bindings.

DescriptionKeyboard shortcut

Inside a p, splits the p in two parts. Elsewhere, normal behaviour.Enter

At the end of a p, if there is no node or text selection, joins this p with following
sibling p if any. Otherwise, normal behaviour.

Del

At the beginning of a p, if there is no node or text selection, joins this p with preceding
sibling p if any. Otherwise, normal behaviour.

BackSpace

Inside a p or inside any list item, inserts same element after this one.Ctrl-Enter

Inside a p or inside any list item, inserts same element before this one.Ctrl+Shit-Enter

Edit referenced topicF2 e

5

XMLmind XML Editor - DITA Support

http://docs.oasis-open.org/dita/v1.0/langspec/topic2.html
http://docs.oasis-open.org/dita/v1.0/langspec/topic2.html


DescriptionKeyboard shortcut

Converts text copied to the clipboard using an external application (Web browser,
word processor, etc) to one or more p elements. Then paste these paragraphs after
implicitly or explicitly selected element.

Esc w

Browse the DITA reference manual found on the OASIS Web siteCtrl-F1

Alt-Drag only works for elements having an id attribute.Alt-Drag

• If an element having an id attribute is explicitly selected and if the mouse is
dragged anywhere over this element, the URL of this element, including a
fragment containing the fully qualified ID of the element, is made available for
a drop.

• If the mouse is dragged outside the node selection if any and if it is dragged
over an element having an id attribute, he URL of this element, including a
fragment containing the fully qualified ID of the element, is made available for
a drop.

This kind of drag is mainly useful to build a DITA map by dropping topicrefs.
See Creating a DITA map using drag and drop.

If the drop occurs above an element having an href attribute other than an image
(e.g. an xref), the dropped string is considered to be an URL and is used to change
the value of the href attribute.

Drop

Note that this kind of drop attempts to relativize the dropped URL against the location
of the drop site. For example, if you drop "file://home/john/doc/topic1.dita"
onto an xref contained in file "file://home/john/doc/ref/reference2.dita",
its href is set to "../topic1.dita".

Elsewhere, normal behaviour which is:

Drop onto an image element
Considers the dropped string to be the URL or the filename of a graphics
file. Displays a dialog box allowing to copy or reference this graphics file
for use by the image element.

Drop elsewhere
Considers the dropped string to be the URL or the filename of an XML
document. Opens this document in XXE.

2.4. Using the indexterm editor

This dialog box, displayed by menu item Topic → Insert or Edit indexterm, allows to edit the selected indexterm
element if any, or to create a new indexterm element and then insert it at caret position otherwise.
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Note that this editor does not allow to modify indexterm elements which are invalid, inconsistent or simply too
complex. In such case, you'll have to revert using the normal editing tool (Edit tool, Attributes tool, etc) in order
to modify such indexterm elements. However, this indexterm editor is sufficiently powerful to fulfill the vast
majority of needs.

We'll explain with examples how to use the indexterm editor.

• If you want to get this kind of entry in your back of the book index:

P
Pet 12

specify Term\Primary=Pet.

• Back of the book index:

P
Pet
    Cat 26

specify Term\Primary=Pet, Term\Secondary=Cat.

• Back of the book index:

P
"+" 54

specify Term\Primary="+", Sort As\Primary=plus. Without this Sort As specification, the index entry
corresponding to "+" would have been found in the Symbols category:

Symbols
"*" 53, 78
"+" 54
"-" 55, 91-95
...

• Back of the book index:

D
Domesticated animals 34 See also Pet

specify Term\Primary=Domesticated animals, See Also=Pet.
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Note that the content of the See Also field must refer to an existing index entry. That's why instead of typing
"Pet", you can select this index entry by using the dialog box displayed by the Pick from list button found
at the right of the See Also row.

It is possible to specify up to two See Also entries for a Term.

• Back of the book index:

F
Felis catus See Pet, Cat

specify Term\Primary=Felis catus, See\Primary=Pet, See\Secondary=Cat. (In the above example,
notice that Felis catus has no associated page number.)

Like See Also, the content of the See field must refer to an existing index entry. Unlike See Also, a See entry
is merely a redirection to an actual index entry.

• Back of the book index:

O
Operation
    Additive
        "+" 87-90

1. Insert a first indexterm element at the beginning the range (this will give us page number 87).

In order to do that, use Topic → Insert or Edit indexterm and specify Term\Primary=Operation,
Term\Secondary=Additive, Term\Tertiary="+", Sort As\Tertiary=plus.

Then check Range/Start and give your range an identifier by specifying "plus_reference" in the
Range field.

2. Insert another indexterm element at the end the range (this will give us page number 90).

In order to do that, use Topic → Insert or Edit indexterm, check Range/End and specify the same
identifier, "plus_reference", in the Range field. All the other fields must be left blank.
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Note that instead of typing "plus_reference" in the Range field, you can select this identifier by using
the dialog box displayed by the Pick from list button found at the right of the Range row.

Related information

➥ The "Insert or Edit indexterm" menu item

3. DITA map reference

3.1. DITA map menu

When a DITA map is opened in XMLmind XML Editor, the XML menu becomes the Map menu and this menu
is populated with items which are specific to DITA maps. This reference contains a description of such menu
items.

Convert Document menu

Note • This menu is absent in XMLmind XML Editor Personal Edition.
• The items of this menu are all disabled if the document being edited needs to be saved to

disk.

Convert to XHTML
Convert to XHTML [one page]

Converts the document being edited to multi page or single page XHTML 1.0.

Convert to HTML Help
Converts the document being edited to a .chm file. This command is disabled on platforms other than
Windows.

Requires:

1. Download and install Microsoft®'s HTML Help Workshop.
2. Declare the HTML Help compiler, hhc.exe, as the helper application associated to files having a

"hhp" extension. This can be specified by using the Preferences dialog box, Helper Applications
section.

Convert to Java Help
Converts the document being edited to a .jar file for use by the Java™ Help system.

Requires:

1. Download and install JavaHelp.
2. Declare the Java™ Help indexer, jhindexer (jhindexer.bat on Windows), as the helper

application associated to files having a "application/x-java-help-index" MIME type. This
can be specified by using the Preferences dialog box, Helper Applications section.

Convert to RTF (Word 2000+)
Converts the document being edited to RTF (Rich Text Format) using. The document generated by this
command can be edited and printed using Microsoft® Word 2000 and above.

Requires downloading and installing the "XMLmind FO Converter XSL-FO processor plug-in " add-on

using Options → Install add-ons.

Convert to WordprocessingML (Word 2003+)
Converts the document being edited to WordprocessingML. The document generated by this command
can be edited and printed using Microsoft® Word 2003 and above.
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Same requirements as Convert to RTF.

Convert to Office Open XML (Word 2007+)
Converts the document being edited to Office Open XML (.docx file) . The document generated by this
command can be edited and printed using Microsoft® Word 2007 and above.

Same requirements as Convert to RTF.

Convert to OpenDocument (OpenOffice.org 2+)
Converts the document being edited to OpenDocument (.odt file). The document generated by this
command can be edited and printed using OpenOffice.org 2.

Same requirements as Convert to RTF.

Print PostScript
Convert the document being edited to PostScript® and send the generated file to the chosen printer.

Requires downloading and installing any of the following add-ons using Options → Install add-ons.

• Apache FOP 1.x XSL-FO processor plug-in;

• RenderX XEP XSL-FO processor plug-in(4).

Convert to PDF
Convert the document being edited to PDF.

Same requirements as Print PostScript.

Changing the look and contents of the files generated by the Convert Document
menu

There are two ways to change the look and contents of the files generated by the items of the Convert Document
menu.

1. Specifying custom XSLT stylesheet parameters. This is done by using Options → Customize Configuration

→ Change Document Conversion Parameters.

For example, selecting parameter group "Convert to HTML Help" and adding parameter number with value
all allows to number the sections of the generated .chm file.

The reference manual of the parameters of the XSLT stylesheets used to perform the conversion is found in
XMLmind DITA Converter Manual - XSLT stylesheets parameters. This reference manual can be directly
accessed from the "Change Document Conversion Parameters" dialog box.

2. To a lesser extent, changing the options of the XMLmind DITA Convert (ditac) preprocessor. This is done

by using Options → Customize Configuration → Preprocessing Options.

For example, selecting option group "Convert to PDF, PostScript" and specifying a .ditaval file in the
"Conditional processing profile" field allows to filter and/or flag the generated .pdf file.

More information about this facility in Section 7.

Note that a technical writer is not expected to know which parameter or which option is to be specified to get the
desired effect. Unless she/he is the local guru, a technical writer is expected to post a support request to the
xmleditor-support public, moderated, mailing list in order to learn this. But at least the two above facilities allow
her/him to customize her/his deliverables without having to hand edit configuration files.

(4)Unlike all the other add-ons, the RenderX XEP XSL-FO processor plug-in is not self-contained. You'll need to download, install
and activate RenderX XEP (for example, free Personal Edition) prior to using the RenderX XEP XSL-FO processor plug-in.
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3.2. DITA map tool bar

When a DITA map is opened in XMLmind XML Editor, buttons which are specific to this kind of document are
automatically added to the tool bar. This reference contains a description of such buttons.

DescriptionButton

Insert a topicref before selected topicref, topichead, topicgroup. Insert topicref before

Append a topicref child element to the selected topicref, topichead,
topicgroup.

 Insert topicref into

Insert a topicref after selected topicref, topichead, topicgroup. Insert topicref after

If selected element is a topicref, topichead, topicgroup, navref or anchor
and if this selected element is preceded by a topicref, topichead, topicgroup,

 Move up

navref or anchor, this command moves selected element one position up in its
container element.

If selected element is a topicref, topichead, topicgroup, navref or anchor
and if this selected element is preceded by a topicref, topichead, topicgroup,

 Move down

navref or anchor, this command moves selected element one position down in its
container element.

If selected element is a topicref, topichead, topicgroup, itself contained in a
topicref, topichead, topicgroup, this command removes selected element
from its parent and makes it a sibling following its ex-parent.

 Promote

Moreover, all elements that followed selected element in the ex-parent are also
removed from this ex-parent and made children of the newly ``promoted'' element.

If selected element is a topicref, topichead, topicgroup, itself preceded by a
topicref, topichead, topicgroup, this command moves selected element at the
end of its predecessor.

 Demote

Opens in XMLmind XML Editor the topic or map referenced in the conref, href
or mapref attribute of selected element.

 Edit referenced topic or
map

If this document is already opened in XMLmind XML Editor, this command brings
its view to front and makes it the active one.

If this document does not exist yet, the File → New dialog box is displayed and
allows the user to choose which document (i.e. topic, task, reference, map, etc)
is to be created at the location specified by attribute href, mapref or conref.

3.3. DITA map bindings

When a DITA map is opened in XMLmind XML Editor, additional keyboard shortcuts which are specific to this
kind of document are automatically made available to the user. This reference contains a description of such
keyboard shortcuts.

DescriptionKeyboard shortcut

Move upF2 Up

Move downF2 Down

PromoteF2 Left
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DescriptionKeyboard shortcut

DemoteF2 Right

Edit referenced topic or mapF2 e

4. DITA bookmap reference

4.1. About DITA bookmap support

When a DITA bookmap is opened in XMLmind XML Editor, the XML menu becomes the BookMap menu and
this menu is populated with items which are specific to DITA bookmaps. Similarly, buttons which are specific to
this kind of document are automatically added to the tool bar. The BookMap menu and tool bar are identical to
those specific to DITA maps.

Related information

➥ Section 3.1. DITA map menu

5. Creating a DITA map using drag and drop

Procedure

1. Use File → New and choose DITA Map | Map.

2. Use File → Save As to give a filename to the newly created map.

3. Drag a reference to a topic:

❍ Using your file manager. Simply drag the icon representing the XML file containing the topic.

❍ OR using your web browser. Simply drag the link to the topic as found in an HTML page (or the
corresponding bookmark icon as found in the location bar).

❍ OR using XXE itself.

In such case, open in XXE the topic you want to reference and click on the dashed line found at the
bottom the tab of the document view to have both the map and the topic side by side.

For this task, it may be more convenient to have one view at the right of the other rather than one view

below the other. To do this, use Options → Quick Preferences → Split Window Vertically.
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– Click anywhere on the document view containing the topic to make sure this document is the active

one and then, drag the file icon(5) found in XXE's node path bar.

– OR, if the DITA file contains several nested topics, first select the topic element you want to

reference as if you wanted to edit it(6) and then drag anywhere inside it while pressing the Alt key
to drag its reference.

Alt-drag allows to drag any element having an id attribute without having to select it first.
However in the case of a container element such as a section or a topic, it is much easier

Note

to first select the element for which you want to drag a reference and then, alt-drag anywhere
inside it.

Note that this drag facility is fully aware of the way elements are referenced in DITA. For
example, if you drag a p element having "audience" as its id attribute and if this p element
is contained in a topic element contained in file file://home/john/doc/topic1.dita
and having "introduction" as its id attribute, you'll end up dragging string
"file://home/john/doc/topic1.dita#introduction/audience".

4. Drop the dragged reference onto the text which immediately follows the link icon of a topicref. This text

is "???" in the case of a newly created topicref such as the one depicted in this screen shot: .

XXE will automatically attempt to make the dropped reference relative to the location of the drop site. If, for
example, you drop file://home/john/doc/topic1.dita onto a topicref element contained in
file://home/john/doc/maps/book.ditamap, its href attribute will contain "../topic1.dita". If
the dropped reference cannot be made relative to the location of the drop site (for example, if it is an http://
URL) then the href attribute will contain the dropped reference as is.

(5)For an unknown reason, this will not work on the Mac.
(6)There are many ways to do this. For example, click several times anywhere inside the topic, while pressing the Ctrl key and without

moving the mouse, until you ̀ `reach'' it. More information in XMLmind XML Editor - User's Guide, "Being productive with XXE".
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6. Content inclusion

6.1. Easy content inclusion

About this task

The conref attribute of an element allows to reference the contents (text, child elements, some of the attributes)
of another element.

Instead of just seeing an empty element having a conref attribute (that is, the ``pointer''), it is nicer to see the
referenced contents. This process is called transclusion and XMLmind XML Editor can do it for you.

Everything explained here should also work for DITA maps.Note

The following procedure (Copy as Reference then Paste) is not specific to DITA. The same procedure could
be used to add references to DocBook or XHTML documents. This is why it is explained in great details in
our tutorial.

Note

Procedure

1. Open in XMLmind XML Editor the topic containing the element you want to reference.

2. Select this element.

Let's call this element the conref source.

3. If this element has no id attribute, specify one using the Attributes tool.

4. Press Ctrl+Shift-C (Edit → Reference → Copy as Reference).

You'll see the name of the element copied as reference displayed in dimmed blue at the bottom right of
XMLmind XML Editor main window.

5. Switch to the topic where you want to create the reference.

6. Use Ctr-U (Edit → Paste Before), Ctrl-V (Edit → Paste) or Ctrl-W (Edit → Paste After) to paste a reference
to the conref source.

Let's call this pasted reference the conref target.
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7. Sometimes, you'll want to add attributes which are specific to the conref target (typically an id attribute). In
such case:

a. Select the conref target.

b. Use Edit → Reference → Untransclude to un-transclude the conref target.

You'll see an element having the same name as the conref source but having no content and having a
conref attribute pointing the conref source.

c. Use the Attributes tool to specify one or more attributes.

d. Use Edit → Reference → Retransclude to re-transclude the conref target.

Related information

➥ Section 6.2. Content inclusion: an alternative, low-level, method

6.2. Content inclusion: an alternative, low-level, method

Procedure

1. Insert the element (the conref target) you wish to transform to a reference to another element contained
elsewhere (the conref source).

You may use Ctrl-H (Edit → Insert Before), Ctrl-I (Edit → Insert) or Ctrl-J (Edit → Insert After) to do
this.

2. Using the Attributes tool, specify an href attribute for the conref target.

Specifying a value for the href attribute is tedious and error-prone. That's why using this method rather than
the easy one described in Section 6.1 is not recommended.

3. Specify other attributes, for example an id attribute, if you want.

4. Use Edit → Reference → Retransclude to transclude the conref target.

Related information

➥ Section 6.1. Easy content inclusion
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7. Preprocessing options

Converting a DITA document to formats such as HTML, PDF, RTF, etc, comprises two steps. First step consists
in preprocessing the DITA document. Second step consists in translating the preprocessed DITA document to the
other format by the means of XSLT stylesheets.

The XSLT stylesheets are parameterized by using Options → Customize Configuration → Change Document

Conversion Parameters, while the preprocessor is parameterized by using Options → Customize Configuration

→ Preprocessing Options. The latter menu item displays a dialog box which is described in this section.

Figure 1. The Preprocessing Options dialog box

The top combobox allows to select the group of options to be edited. Each group of options is completely separated
from the other. For example, specifying tfilter2.ditaval as the conditional processing profile of "Convert

to single-page XHTML" will have an effect when you'll use Map → Convert Document → Convert to XHTML

[one page] and no effect at all when you'll use Map → Convert Document → Convert to HTML Help(7).

Default language
Specifies the main language of the document. Examples: en, en-US, fr, fr-CA. This information is
needed in order to sort the index entries. By default, this information is taken from the xml:lang attribute
of the root element of the topic map (if any, "en" otherwise).

Conditional processing profile
Apply specified conditional processing profile (a .ditaval file) to the topics.

The buttons found at the top/right of this field allow respectively to:

• clear this field;
• edit, or simply view, the .ditaval file specified in this field;
• specify the URL of a .ditaval file by selecting it using a file chooser dialog box.

(7)Or when you'll use Topic → Convert Document → Convert to XHTML [one page]. There is a separate "Convert to single-page
XHTML" group of options for the Map, BookMap and Topic configurations.
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Table of Contents
Specifies whether to automatically generate a Table of Contents and, if a Table of Contents is to be
generated, where to generate it. Frontmatter means at the beginning of the document. Backmatter means
at the end of the document.

This option, like List of Figures, List of Tables, List of Examples and Index, is mainly useful when
working with maps or individual topics. When working with a bookmap, the preferred way to specify
the location, if any, of a Table of Contents is to do it in the bookmap itself. In all cases, what's specified
in the bookmap has priority over the value of this option.

List of Figures
Specifies whether to automatically generate a List of Figures and, if a List of Figures is to be generated,
where to generate it.

List of Tables
Specifies whether to automatically generate a List of Tables and, if a List of Tables is to be generated,
where to generate it.

List of Examples
Specifies whether to automatically generate a List of Examples and, if a List of Examples is to be
generated, where to generate it.

Index
Specifies whether to automatically generate an Index and, if an Index is to be generated, where to
generate it.

Copy images to
Copy the image files referenced in the topics to specified directory. If specified path is relative, it is
relative to the output directory.

When this field is left empty, the generated document will reference the image files using absolute URLs.
This is harmless for PDF, RTF, etc, files because at the end of the conversion process, such files will
embed a copy of the image files. However, this is rarely what is wanted for HTML-based formats
(XHTML, Java Help, HTML Help, etc).

Chunk mode
Allowed values are Automatic, Single and None.

Chunk Automatic means: ignore the chunk specification found in the topic map and output a single
chunk for the Print medium; honor the chunk specification for the Screen medium.

Chunk None means ignore the chunk specification found in the topic map and output a single chunk.
As explained above, chunk None is implicit for some formats (PostScript, PDF, RTF, etc),

Both the None and Single values may be used to force the generation of a single output file. Chunk
Single allows to reuse a map designed to output multiple HTML pages in order to generate a single
HTML file or a PDF file.

Target medium
Explicitly specifies the output medium: Screen (XHTML, HTML Help, Eclipse Help, etc) or Print
(PDF, RTF, etc). By default, the output media is guessed using the extension of the output file.

Preprocessor messages
Specifies the level of verbosity of the preprocessor. Allowed values are (from not verbose to very verbose):
None, Information, Verbose, Debug.

Some fields may be ``grayed out'' (disabled). This happens in two cases:

1. The DITA configuration has been customized by the local guru. This automatically prevents the end user
from making any change to the preprocessing options.

2. Changing the values of some options (typically Chunk mode, Target medium, etc) would break the stock
configuration.
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